Category Archives: Issues/Troubleshooting

VM on VM: Enable Hyper-V role on Windows Server 2012 inside VMWare

If you ever tried to install Windows Server 2012/R2 on VMWare Workstation, and enable the Hyper-V role, you would have probably encountered the following error:

Hyper-V cannot be installed: A hypervisor is already running

The trick to allowing this Hyper-V on VMware is in two settings:

Read more

Advertisements

Connection Error 233 : No process at the other end of the pipe

Just had an interesting error the other day.

Got this error when trying to connect one of our servers that has just been patched:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 – No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

Typically, to troubleshoot this, you go to SQL Server Configuration Manager (SSCM) and:
1. ensure Shared Memory protocol is enabled
2. ensure Named Pipes protocol is enabled
3. ensure TCP/IP is enabled, and s ahead of the Named Pipes in the settings

Check out Pinal Dave’s excellent post on this.

All of these are set in our server.

Next up, I checked the log files. Logs are typically located in a folder similar to this (note you will need to change the folder MSSQL.1 with the appropriate instance name’s folder name):
C:Program FilesMicrosoft SQL ServerMSSQL.1MSSQLLOG

When I checked the logs however, I got yet another interesting error:

Could not connect because the maximum number of ‘1’ user connections has already been reached. The system administrator can use sp_configure to increase the maximum value. The connection has been closed. [CLIENT: ]

It’s an interesting error because:
1. We just restarted the server and nobody is able to access it yet
2. DAC is disabled

Read more

Troubleshooting Replication Error: A required privilege is not held by the client

Troubleshooting Replication Error: A required privilege is not held by the client

If you ever you encounter this replication issue, the resolution might be fairly simple, however it will require that you toggle your SQL Service accounts.

Have a look at this KB:
http://support.microsoft.com/kb/911305/en-us

The KB suggests the service account might have changed using a tool other than the Configuration Manager (technically a no-no because the SSCM, in addition to changing the service accounts, also performs updates to associated settings like windows registry entries). Try toggling the service accounts in Configuration Manager (for ex, from Administrator, to something Local, to administrator again) and that should flush the old credentials.

Read more

Invalid Credentials Error During SQL Server 2008/R2 Install

In case you get the following errors:

The credentials you provided for the SQL Server Agent service are invalid. To continue, provide a valid account and password for the SQL Server Agent service.

The specified credentials for the SQL Server service are not valid. To continue, provide a valid account and password for the SQL Server service.

Here’s the simple solution:
http://www.jadota.com/2009/01/the-credentials-you-provided-during-sql-server-2008-install-are-invalid/

« Older Entries